đģ NetBSD Installation
This page was created before 2020
Please refere to NetBSD: The NetBSD Guide for up to date installation instructions
To use CD sets for full installation
dd if=/dir/NetBSD-(version)-amd64-install.img of=/dev/sdX bs=8M; sync
vi /etc/wpa_supplicant.conf
++ network={ ++ ssid="yourssid" ++ scan_ssid=1 ++ key_mgmt=WPA-PSK ++ psk="yourpsk" ++ }
vi /etc/rc.conf
++ dhcpcd_flags="-q -b" ++ wpa_supplicant="YES" ++ wpa_supplicant_flags="-B -i ath0 -c /etc/wpa_supplicant.conf"
vi /etc/ifconfig.ath0
++ up ++ dhcp
/etc/rc.d/wpa_supplicant start
/etc/rc.d/network restart
fdisk
Prints disk names
/sbin/mount -u -w /dev/sd0a /
Remove leading
r
.e.g.s/rsd0a/sd0a/g
/sbin/mount -u -w /dev/sd0a /
export TERM=vt220
vi /etc/fstab
magical incantations (sd1a to sd0a)
I can’t remember why I wrote this line
vi /etc/rc.conf
-- rc_configured=NO ++ rc_configured=YES
Self verified certifications
git config --global http.sslVerify false